Configuring A Client

An antenna MUST be connected to the radio at all times when it is powered on, Not having an antenna connected will result in damage to the radio!!!
These instructions are a work in progress and are unlikely to result in a working connection

Preface

This describes one simple method of configuring your radio modem to connect to HamWAN. It will configure your radio to be used connected directly to a computer(s) without another internet connection. It will provide a provide DHCP address to computers connected over ethernet and will have a public 44.x.x.x address on the wireless side.

Understanding What HamWAN Is and Isn't

  • Who can use it?
    • Anyone with a valid Amateur Radio license can use our network
  • What can it be used for?
    • Primarily the network is intended to serve as an emergency communications system
    • Encrypted Traffic is not allowed
    • Commercial traffic is prohibited

Integration With An Existing Network

Integrating HamWAN with an existing network is not a simple task an involves complex networking concepts and may be beyond the capabilities of your home networking equipment.

Configuration Steps

These steps should get you on the air but do not include any local networking (radio will have HamWAN access but your computer will not)

  1. Upgrade your modem to the latest version of RouterOS
    • If you have connected the modem to your LAN in a way that provides Internet access, the following command can be used:
      /system package update upgrade
    • Otherwise, use the standalone upgrade method: http://wiki.mikrotik.com/wiki/Manual:Upgrading_RouterOS (also works on older ROS 5.xx that does not support the upgrade command)
  2. Reset the router to a blank configuration.
    /system reset-configuration no-defaults=yes
  3. Give your modem a name, use your callsign so that we can easily identify the owner of this radio
    /system identity set name=MYCALL
     Note: PDSR does this differently and wants you to suffix your callsign with the name of the site you are connecting too. Its unclear why they do this as it just makes roaming more complicated.
    
  4. Set a password for the admin user
    /user set admin password=
    /console clear-history

    This is an example password generated in your browser. You may choose any password you like.

  5. To support shared administration, add the following HamWAN Network Administration accounts into the "full" group. Usernames are case sensitive.
    /user add group=full name=manage password=
    /console clear-history

    The passwords above are randomly generated in your browser, not stored anywhere, and will never be used. Any HamWAN access to your modem will be done with certificates.

  6. In the PDSR instructions you would install the Shared Administrator SSH Certificates here. This is much easier once you are connected to the network so we do this at the end.
  7. Enable Ethernet boot in case you ever need to reinstall the router with NetInstall (this could save you a trip up to your roof, its a good idea)
    /system routerboard settings set boot-device=try-ethernet-once-then-nand
  8. Configure Remote Central Logging
    /system logging action set 3 bsd-syslog=no name=remote remote=44.135.216.4 remote-port=514 src-address=0.0.0.0 syslog-facility=daemon syslog-severity=auto target=remote
    /system logging add action=remote disabled=no prefix="" topics=info
    /system logging add action=remote disabled=no prefix="" topics=warning
    /system logging add action=remote disabled=no prefix="" topics=error
    
  9. SNMP Monitoring
    /snmp set enabled=yes contact="#HamWAN on irc.freenode.org"
    /snmp community set name=hamwan addresses=44.135.216.0/23 read-access=yes write-access=no numbers=0 trap-version=2
  10. Setup NTP Skip this step for now we do not yet have a network time server
  11. Clear the firewall rules
    /ip firewall filter remove [find dynamic=no]
    

  12. Set the HamWAN Maximum Transmission Unit (MTU) policy TODO: We need to make sure this is correct for our network
    /ip firewall mangle
    add action=change-mss chain=output new-mss=1378 protocol=tcp tcp-flags=syn tcp-mss=!0-1378
    add action=change-mss chain=forward new-mss=1378 protocol=tcp tcp-flags=syn tcp-mss=!0-1378
    
  13. Remove local DHCP server
    /ip dhcp-server remove [find]
    /ip dhcp-server network remove [find]
      
  14. Remove local IP address
    /ip address remove [find]
  15. Disable DNS Service Important!!!
    /ip dns set allow-remote-requests=no
  16. Add HamWAN sector channels. HamWAN uses custom channels outside the normal frequency range for 5ghz WiFi, you need to add these channels to the radio. Currently all of our sector sites use 10mhz channels but you should add both 5 and 10 variants to be safe.
    /interface wireless channels add band=5ghz-onlyn comment="Cell sites radiate this at 0 degrees (north)" frequency=5920 list=HamWAN name=Sector1-5 width=5
    /interface wireless channels add band=5ghz-onlyn comment="Cell sites radiate this at 120 degrees (south-east)" frequency=5900 list=HamWAN name=Sector2-5 width=5
    /interface wireless channels add band=5ghz-onlyn comment="Cell sites radiate this at 240 degrees (south-west)" frequency=5880 list=HamWAN name=Sector3-5 width=5
    
    /interface wireless channels add band=5ghz-onlyn comment="Cell sites radiate this at 0 degrees (north)" frequency=5920 list=HamWAN name=Sector1-10 width=10
    /interface wireless channels add band=5ghz-onlyn comment="Cell sites radiate this at 120 degrees (south-east)" frequency=5900 list=HamWAN name=Sector2-10 width=10
    /interface wireless channels add band=5ghz-onlyn comment="Cell sites radiate this at 240 degrees (south-west)" frequency=5880 list=HamWAN name=Sector3-10 width=10
    
  17. Configure the modem to announce your callsign
    /interface wireless set 0 radio-name="MYCALL"
     Note: PDSR does this differently and wants you to suffix your callsign with your location and the site your connecting to. Its unclear why they do this as it just makes roaming more complicated.
    
  18. Set your location, so that your station shows up on the HamWAN map. Supply your latitude and longitude in decimal degrees separated by a comma, like location=47.1234,-121.1234.
    /snmp set location=LAT,LON
  19. Configure the wireless card to connect to HamWAN
    /interface wireless set 0 disabled=no frequency-mode=superchannel band=5ghz-onlyn mode=station scan-list="HamWAN" ssid=HamWAN wireless-protocol=nv2
  20. Configure your modem to request a DHCP address from the HamWAN network.
    /ip dhcp-client add add-default-route=yes dhcp-options=hostname,clientid disabled=no interface=wlan1
    


  1. Now that you have an internet connection install the keys that support shared administration. Note username are case sensitive.
    Download:
    /tool fetch url="http://portal.hamwan.ca/users/keys/sshkey-manage.pub" dst-path=sshkey-manage.pub; 
    

    Install:

    /user ssh-keys import public-key-file=sshkey-manage.pub user=manage
    

    The passwords above are randomly generated in your browser, not stored anywhere, and will never be used. Any HamWAN access to your modem will be done with certificates.

Next Steps

Integrating HamWAN into your LAN

There are a number of ways to integrate HamWAN into your local network - dedicated local network for HamWAN use. We will discuss only the simplest here for now. PDSR has an in depth article describing other methods here.


Create an isolated LAN for use with HamWAN

Remember to ensure you are within the restrictions of your license it is important to fully understand your network implementation and how traffic will move through it. In this simple configuration all WAN bound traffic will be transmitted/received over your HamWAN radio.

  1. Assign an IP address to your modem's LAN port
    /ip address add address=192.168.88.1/24 interface=ether1
    
  2. Configure DHCP server
    /ip pool add name=dhcp-pool ranges=192.168.88.100-192.168.88.199
    /ip dhcp-server network add address=192.168.88.0/24 dns-server=44.135.216.2,44.135.216.3 gateway=192.168.88.1
    /ip dhcp-server add address-pool=dhcp-pool interface=ether1 name=dhcp disabled=no
    
  3. Configure NAT (Network Address Translation)
    /ip firewall nat add chain=srcnat action=masquerade out-interface=wlan1
    
  4. Connect one end of an Ethernet cable to your modem and the other to the PoE injector (the injector included with the Metal feeds power to the socket side of the adapter). Plug the injector directly into your PC, or into a switch for use with multiple PCs. The modem will assign IP addresses to connected PCs and route their packets to HamWAN.

Example of VA7DBD.client VA7DBD's Client Radio Config


The contents of this page have been republished from the OCARC wiki - http://wiki.ocarc.ca/index.php?title=Client_Node_Configuration